EverKB

Knowledge Base Ever

Spør når du endrer passord i kommandolinjen MySQL8: 1819 (HY000): Your password does not satisfy the current policy requirements

2019-11-15 11:33:27

tag: MySQL8,password,password policy requirements,

Problem: Når MySQL-kommandolinjen endrer passordet, oppfyller ikke ledetekstpassordet kravene.

1819 (HY000): Your password does not satisfy the current policy requirements

Løsning: Sjekk gjeldende passordverifiseringspolicy. Hvis den brukes i utviklingsmiljøet, kan den settes til minimumskravet. Hvis det er et produksjonsmiljø, må det modifiseres nøye.

SHOW VARIABLES LIKE 'validate_password%';
SET global validate_password.policy=0;

tag

CentOS7 CentOS PHP Linux Python3 Python MySQL MariaDB YUM JavaScript CSS Redis MySQL8 caching_sha2_password HTML mysql_native_password PHP7 ShadowsocksR vertical-align CURLFille horiz-align node.js SUBDATE BarManager exec mb_substr PyCharm SOCKS5 Proxy Server WebStorm date add IntelliJIDEA PEAR remi Tag Chrome find src Apache du jQuery PHP5.5 Shadowsocks-Python V2Ray cURL hide nginx sub folder availability eth0 MariaDB10.4 PostgreSQL SOCKS5 Web Server date Install MongoDB pdo_sqlsrv register_shutdown_function Symfony File Upload mssql-tools sqlsrv Zend Framework ADDDATE DevExpress JetBrain php-fpm Shadowsocks-Libev unixODBC-devel height network interface string Aura error_get_last Port 80 SOCKS Web Development data INDENTIFIED BY password policy requirements Redis5 SVN Fedora Media Writer msodbcsql SQLAlchemy absolute Deepin jemalloc Shadowsocks toggle convert FuelPHP mysqlclient ss5.passwd at-symbol Error Control Operator margin PHPUnit Framework SOCKET vps daemon process IIS password sudoers center Fatal Errors MongoDB4 SQL Server 2017 WiFi .htaccess DATE_SUB Phalcon set_error_handler TestCase Compiling PHP frequency conflict ss5.conf apr Elasticsearch7.3 PHPUnit Slim Vincent Garreau daemon HTTP particles.js Sudo Failed to build these modules: _uuid MongoDB SQL Server width DATE_ADD ip command pg_bha.conf scrollbar Tcp BBR Compiling Apache Frameworks MySQL-python ss5-3.8.9 Apache2.4 Elasticsearch libpython3.7m.so.1.0 PHPStorm show VIM CURLOPT_POSTFIELDS NodeJs substr Bluetooth Failed to build these modules: _ctypes Minimal ISO SQL Date Funcitons Wi-Fi date sub INTERVAL PECL root Tag Cloud CodeIgniter font-size ss5 apache httpd dual network interfaces Laravel